FIXING Configuration Error– ‘oracleDBBinding’ could not be found

This error shows up with web applications and/or web services that use the Biztalk LOB Adapters for Oracle and the server doesn´t have the required assemblies.

image

To fix it just install:

The WCF LOB Adapter

image

Then the biztalk adapter pack

image

And declare the binding either on the machine.config for the whole server or in the web.config of the particular web app

  <system.serviceModel>

<extensions>
<bindingElementExtensions>
<add name=”oracleDBAdapter” type=”Microsoft.Adapters.OracleDB.OracleDBAdapterExtensionElement,Microsoft.Adapters.OracleDB, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35″ />
</bindingElementExtensions>
<bindingExtensions>
<add name=”oracleDBBinding” type=”Microsoft.Adapters.OracleDB.OracleDBAdapterBindingSection,Microsoft.Adapters.OracleDB, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35″ />
</bindingExtensio
  </system.serviceModel>

Both downloads can be found easily on the Microsoft Downloads web site

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: